Sucess instal, but nothing append



  • I have complete instalation ,
    i am running in my home serv

    doc . root in apache : var/www/personalpage/public

    site : sysbase.cf

    but i dont see front end , and backend

    i thing sysbase.cf/en/ -> front end
    sysbase.cf/backend -> backend

    why ?? permission on serv ??



  • My fail-proof recommendation:

    Let the apache's httpd.conf untouched, and do the following (VirtualHosts are the way to go, you'll never know if you want more than one site on your server, and by this way you can have multiple):

    • cd /etc/apache2/sites-available
    • sudo cp 000-default.conf 001-sysbase-cf.conf
    • sudo vim 001-sysbase-cf.conf [You can use vim or any text editor like nano or subl but must call it with sudo]

    Your 001-sysbase-cf.conf should be like this one:

    <VirtualHost *:80>
            # The ServerName directive sets the request scheme, hostname and port that
            # the server uses to identify itself. This is used when creating
            # redirection URLs. In the context of virtual hosts, the ServerName
            # specifies what hostname must appear in the request's Host: header to
            # match this virtual host. For the default virtual host (this file) this
            # value is not decisive as it is used as a last resort host regardless.
            # However, you must set it for any further virtual host explicitly.
            #ServerName www.example.com
    
            ServerAdmin your_email@example.org
            DocumentRoot /var/www/personalpage/public
            ServerName sysbase.cf
            ServerAlias *.sysbase.cf
    
            <Directory /var/www/personalpage/public>
                    AllowOverride all
                    Require all granted
            </Directory>
    
    
            # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
            # error, crit, alert, emerg.
            # It is also possible to configure the loglevel for particular
            # modules, e.g.
            #LogLevel info ssl:warn
    
            ErrorLog ${APACHE_LOG_DIR}/sysbase_cf_error.log
            CustomLog ${APACHE_LOG_DIR}/sysbase_cf_access.log combined
    
            # For most configuration files from conf-available/, which are
            # enabled or disabled at a global level, it is possible to
            # include a line for only one particular virtual host. For example the
            # following line enables the CGI configuration for this host only
            # after it has been globally disabled with "a2disconf".
            #Include conf-available/serve-cgi-bin.conf
    </VirtualHost>
    
    # vim: syntax=apache ts=4 sw=4 sts=4 sr noet
    
    • Save your file and test your config is correct by typing: sudo apachectl -t. If the message Syntax OK appears, everything is going fine.
    • Then activate the site by typing sudo a2ensite 001-sysbase-cf.conf
    • And finally restart the server sudo service apache2 reload

    And you're good to go!

    • Remember to set proper permisisons on /storage folder. You can do this via chmod or as I usually do:
      • sudo setfacl -R -m u:www-data:rwx storage/
      • sudo setfacl -R -d -m u:www-data:rwx storage/

    And that's all the required setup!



  • the same problem !!!

    sysbase.cf

    i try , but , i dont now why the server dont find the url



  • @tiago

    Checklist:

    • Do you have the Apache's mod-rewrite enabled?

      • Install apache2-utils if you haven't it installed by: sudo apt-get install apache2-utils
      • Once installed check you've mod-rewrite enabled by: sudo a2enmod rewrite
    • Check your /etc/apache2/apache2.conf has this lines:

    <Directory /var/www/>
            Options Indexes FollowSymLinks
            AllowOverride None
            Require all granted
    </Directory>
    
    • Once activated mod-rewrite and your apache2.conf is correct, restart apache2 server: sudo service apache2 reload

    That should work.



  • drwxr-xr-x 11 root root 4096 Apr 19 12:02 app
    -rw-r--r-- 1 root root 1635 Apr 19 12:02 artisan
    drwxr-xr-x 3 root root 4096 Apr 19 12:02 bootstrap
    -rw-r--r-- 1 root root 1789 Apr 19 12:02 composer.json
    -rw-r--r-- 1 root root 190961 May 3 00:37 composer.lock
    drwxr-xr-x 2 root root 4096 May 3 00:41 config

    drwxr-xr-x 4 root root 4096 Apr 19 12:02 database
    -rw-r--r-- 1 root root 503 Apr 19 12:02 gulpfile.js
    drwxr-xr-x 11 root root 4096 May 3 00:34 Modules
    -rw-r--r-- 1 root root 79 Apr 19 12:02 package.json
    -rw-r--r-- 1 root root 87 Apr 19 12:02 phpspec.yml
    -rw-r--r-- 1 root root 729 Apr 19 12:02 phpunit.xml
    drwxr-xr-x 6 root root 4096 Apr 19 12:02 public
    -rw-r--r-- 1 root root 4977 Apr 19 12:02 readme.md
    drwxr-xr-x 5 root root 4096 Apr 19 12:02 resources
    -rw-r--r-- 1 root root 561 Apr 19 12:02 server.php
    drwxrwxr-x+ 6 root root 4096 Apr 19 12:02 storage
    drwxr-xr-x 2 root root 4096 Apr 19 12:02 tests
    drwxr-xr-x 4 root root 4096 May 3 00:35 Them

    es
    drwxr-xr-x 42 root root 4096 May 3 00:39 vendor



  • @tiago

    Hi, could you put in some context about your post? At first glance it seems a directory list of the project, and as far I can guess, permissions are fine. (Notice the drwxrwxr-x+ in folder storage.
    Just notice that ownership and group is root, so keep it in mind when you edit files, or if you have more permission problems.

    Also, if you want to paste some code or output, it will be helpful for everyone to use the appropiate markdown.

    Now let's go to the meat: did you tried to enable mod-rewrite ? What have you tried so far?

    The more information you provide, the better we'll be able to help you! :)



  • Yes, i try .... But not work



  • I cannot help you more If you don't provide more debugging information :(

    Check you have these lines verbatim in your /etc/apache2/apache2.conf (you're likely to find them in the ending of the file):

    # Include the virtual host configurations:
    IncludeOptional sites-enabled/*.conf
    

    Restart apache, try again and provide some feedback (errors, console output, etcetera...)


Log in to reply