Problem running a server



  • Hello,

    I instaled asgard via composer and asgard:install.

    And my server doesn't run when I type art serve command.

    What should I do?



  • @andrius

    And my server doesn't run when I type art serve command.

    Can you elaborate a bit more what is going wrong? Any error messages? Any output? Absolutely nothing at all?



  • Here's a link of my screenshot



  • All right, now I see what is going on.

    I'll write in my reply the error you got, so it can be searched (an screenshot cannot):

    PHP NOTICE: Use of undefined constant MCRYPT_RIJNDAEL_128 - assumed 'MCRYPT_RIJNDAEL_128' in /var/www/html/mycms/config/app.php on line 101

    Check if you have installed and activated the PHP's mcrypt extension.

    Fix instructions (on Ubuntu / Debian):

    • Type on your shell:
      sudo apt-get install php5-mcrypt

    • Then restart Apache by:
      sudo service apache2 reload

    • Then you should reinstall the app:

      • Drop the database you created.
      • Create again the database.
      • Wipe the directory composer created on first step (in your case /var/www/html/mycms).
      • Reinstall the application again, with:
        composer create-project asgardcms/platform your-project-name and php artisan asgard:install. If the Asgard Installer makes you some questions, you're good to go :)


  • Thank you for your effort, but I got same problem.



  • Run the following command:

    sudo php5enmod mcrypt

    If that doesn't work, check your php.ini to see if the mcrypt extension is enabled

    Restart apache and try to reinstall again the project.


Log in to reply
 

Looks like your connection to AsgardCms was lost, please wait while we try to reconnect.