Sidebar not showing

  • My sidebar is not showing for all the module with 2 words, e.g. ApiUser, ImageDimension, ReviewImage. Even I changed the content of SidebarExtender.php to something with error '<?php bla bla bla ?>' the page will still load.

    Other module like Restaurant, Review just worked fine.

  • Global Moderator

    @esien525 Yeah it seems it's in core dependency outside of Asgard itself.
    Created issue on github #182

    For now you could try editing core file, in here change line with $name = $module->get('name', $module->getStudlyName()); or $name = $module->get('name', $module->getName());

    See how it works out if there are any problems with that.

  • @armababy you just solved my problem. Thanks for the solution in github #182.

    Simply replace $name = studly_case($module->getName()); with $name = $module->get('name', $module->getStudlyName()); and it works.

Log in to reply

Looks like your connection to AsgardCms was lost, please wait while we try to reconnect.