Installation problems with dependences



  • I am a experienced laravel developer so when I saw Asgard CMS, and that it uses Laravel, I thought I would give it a try.

    I am trying to install it onto a UniServerZ vhosts, I have other Laravel apps running fine in the same configuration but when trying to create the platform (first install command) I have the error below.

    [RuntimeException]
    Could not load package intervention/image in http://packagist.org: [Unexpec
    tedValueException] Could not parse version constraint 4.x.x: Invalid versio
    n string "4.x.x"

    [UnexpectedValueException]
    Could not parse version constraint 4.x.x: Invalid version string "4.x.x"

    I have tried installing earlier version but I have the same error. Can anyone help please?

    The vendor folder disappears after this error appears.

    Thank you

    Stephen


  • Global Moderator

    Very interesting, i wonder where does that 4.x.x version come from since Media module requires ^2.3 < 3.0 version.
    Is you composer updated? I remember some time ago i saw errors like that with outdated composer itself.



  • Thank you for the advise. Although it was not the solution it did point me in the correct direction.

    I updated composer and had a more useful error message, stating that I had not enabled the fileinfo php extension. I enabled it, and it still did not work as it needed to be enabled in the php-cli.ini file so that it would work in the command line.

    Having fixed that error, I am now getting error from mySQL, stating that it could not create a table.


  • Global Moderator

    @stephenrmiles Any specifics or just says can't create table? Is there .env file in project root?


Log in to reply
 

Looks like your connection to AsgardCms was lost, please wait while we try to reconnect.