Pb for installation on CentOS7/virtuabox5.26/mariadb/httpd

  • Hello there,

    I really would like to give a try with AsgardCMS to see how cool it is.
    But I'm stuck with my installation on a "CentOSv7 virtualbox guest".

    The configuration:

    CentOS Linux release 7.3.1611 (Core) 


       10  yum install kernel-devel
       15  yum install -y bzip2
       21  yum install kernel-header
       46  yum install gcc
       47  yum install -y make
      116  yum install epel-release
      117  yum install ius
      118  yum install ius-release
      125  yum install -y ius-release
      126  yum install -y epel-release
      134  yum install -y php71u
      138  yum install -y php71u-cli
      147  yum install -y php71u-json
      151  yum install -y php71u-pdo
      164  yum install -y php71u-common
      167  yum install -y php71u-mbstring
      169  yum install -y php71u-mcrypt
      171  yum install -y php71u-gd
      177  yum install -y memcached
      179  yum install -y php71u-pecl-memcached
      183  yum install -y mariadb
      184  yum install -y mariadb-server
      193  yum install -y httpd
      202  yum install -y php71u-mysqlnd

    services on:

    UNIT FILE                                   STATE  
    auditd.service                              enabled
    autovt@.service                             enabled
    chronyd.service                             enabled
    crond.service                               enabled
    dbus-org.fedoraproject.FirewallD1.service   enabled
    dbus-org.freedesktop.NetworkManager.service enabled
    dbus-org.freedesktop.nm-dispatcher.service  enabled
    firewalld.service                           enabled
    getty@.service                              enabled
    irqbalance.service                          enabled
    lvm2-monitor.service                        enabled
    microcode.service                           enabled
    NetworkManager-dispatcher.service           enabled
    NetworkManager.service                      enabled
    postfix.service                             enabled
    rsyslog.service                             enabled
    sshd.service                                enabled
    systemd-readahead-collect.service           enabled
    systemd-readahead-drop.service              enabled
    systemd-readahead-replay.service            enabled
    tuned.service                               enabled
    vboxadd-service.service                     enabled
    vboxadd-x11.service                         enabled
    vboxadd.service                             enabled

    I have follow the documentation instructions for installing asgard:

    222 composer global require asgardcms/asgardcms-installer
    223 asgardcms new fmjconsulting

    followed and answered the questions of
    php artisan asgard:install
    [root@localhost fmjconsulting]# php artisan asgard:install

    Starting the installation process...

    Enter your database driver (e.g. mysql, pgsql) [mysql]:


    Enter your database host []:


    Enter your database port [3306]:


    Enter your database name [homestead]:


    Enter your database username [homestead]:


    Enter your database password (leave <none> for no password) [secret]:


    Database successfully configured

    User Module
    Starting the User Module setup...

    Enter your first name:


    Enter your last name:


    Enter your email address:


    Enter a password:


    Please confirm your password:

    Admin account created!

    Do you want to remove composer.lock from .gitignore ? (yes/no) [yes]:

    Platform ready! You can now login with your username and password at /backend

    I have change all the files permissions to apache:apache under my /var/www/fmjconsulting folder
    and add a .htaccess at the root (/var/www/)

    But I don't know how to access my login page or the administrations page.
    I have tried a php artisan serve, without any success.
    I always end with the forbidden access message

    alt text
    alt text

    Is someone could help me on that?

  • I have changed my httpd.conf to set the DocumentRoot pointing to the public directory.
    I don't know if it's a good practrice for the laravel framework.

    # DocumentRoot: The directory out of which you will serve your
    # documents. By default, all requests are taken from this directory, but
    # symbolic links and aliases may be used to point to other locations.
    DocumentRoot "/var/www/fmjconsulting/public"
    # Relax access to content within /var/www/fmjconsulting.
    <Directory "/var/www/fmjconsulting">
        Options FollowSymlinks
        AllowOverride All
        # Allow open access:
        Require all granted

    And I have forgot to mention that I have changed

    • the selinux context during the installation,
    • so than the ipatbles rules,
    • and firewalld status.

  • Global Moderator

    @fredmj that is expected from Laravel to point your docroot to public folder of Laravel (Asgard). Good you solved that for yourself.

Log in to reply

Looks like your connection to AsgardCms was lost, please wait while we try to reconnect.