Installation



  • I really wanted to try out this CMS, but it doesn't seem your installation works at all... Note I'm NOT a newbie to Laravel....

    Tried the composer install... got a message to create a github token... never had that before from any other install... finally got the token, and continued, only to get the following...:

    C:\Users\rbgie_000\Code53>composer create-project asgardcms/platform mytestproject
    The "franzl/studio" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
    The "franzl/studio" plugin was skipped because it requires a Plugin API version ("1.0.0") that does not match your Composer installation ("1.1.0"). You may need to run composer update with the "--no-plugins" option.
    Installing asgardcms/platform (1.14.1)

    Problem 1
    - The requested package pingpong/modules dev-feature/5.1 exists as pingpong/modules[1.0.0, 1.0.1, 1.0.10, 1.0.11, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7,
    1.0.8, 1.0.9, 1.0.x-dev, 1.1.0, 1.1.1, 1.1.10, 1.1.11, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.1.6, 1.1.7, 1.1.8, 1.1.9, 1.2.0, 1.2.1, 2.0.0, 2.0.10, 2.0.11, 2.0.12, 2.0.13, 2.0.14, 2.0.17, 2.0.18, 2.0.2, 2.0.21, 2.0.4, 2.0.6, 2.0.7, 2.0.8, 2.0.x-dev, 2.1.x-dev, 2.2.x-dev, dev-master, v2.1.0, v2.1.4, v2.1.5, v2.1.6, v2.2.0] but
    these are rejected by your constraint.
    Problem 2
    - asgardcms/core-module 1.0.x-dev requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.9.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.8.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.7.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.6.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.5.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.4.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.3.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.24.3 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.24.2 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.24.1 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.24.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.23.2 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.23.1 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.23.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.22.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.21.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.20.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.2.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.19.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.18.1 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.18.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.17.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.16.1 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.16.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.15.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.14.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.13.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.12.1 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.12.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.11.2 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.11.1 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.11.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.10.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.1.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.0.9 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.0.8 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.0.7 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.0.6 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.0.5 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.0.4 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.0.3 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.0.2 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.0.12 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.0.11 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.0.10 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.0.1 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - asgardcms/core-module 1.0.0 requires pingpong/modules dev-feature/5.1 -> no matching package found.
    - Installation request for asgardcms/core-module ~1.0 -> satisfiable by asgardcms/core-module[1.0.0, 1.0.1, 1.0.10, 1.0.11, 1.0.12, 1.0.2, 1.0.3, 1.0.4, 1.0.5, 1.0.6, 1.0.7, 1.0.8, 1.0.9, 1.1.0, 1.10.0, 1.11.0, 1.11.1, 1.11.2, 1.12.0, 1.12.1, 1.13.0, 1.14.0, 1.15.0, 1.16.0, 1.16.1, 1.17.0, 1.18.0, 1.18.1, 1.19.0, 1.2.0, 1.20.0, 1.21.0, 1.22.0, 1.23.0, 1.23.1, 1.23.2, 1.24.0, 1.24.1, 1.24.2, 1.24.3, 1.3.0, 1.4.0, 1.5.0, 1.6.0, 1.7.0, 1.8.0, 1.9.0, 1.0.x-dev].

    Potential causes:

    Read https://getcomposer.org/doc/articles/troubleshooting.md for further common problems.

    However, it looked like most of it was on disk, so I tried composer udpate... That went pretty well, so I tried the install.... I put the CORRECT info in for the DB info.... and it absolutely won't accept it.... no matter what I tried, the DB info stuff just kept repeating....

    NOTE, that I'm developing on Homestead, but I don't use MySQl on Homestead. I run a MySQL database on my local machine... don't think that should be problem (at least it hasn't been for the more than 40 Laravel projects I have developed).... but thought I'd mention it in case something in your install can't handle it....

    I guess I can fix the PingPong dependency and try the install again...

    Any suggestions on how I might be able to try this CMS out?


  • Global Moderator

    Hi @bgies

    Sorry for you experience with the install.
    I'm not sure for version 1 install as I have not installed that in very long time.

    But if you want to try out CMS I suggest you go with version 2 it's quite stable (i would say in a pair or even more stable than v1).

    To install v2 you would do composer create-project asgardcms/platform:2.0.x-dev mytestproject.

    Hope you will have good experience with CMS (or actually I don't consider this CMS, more like development framework to build stuff).



  • I did finally solve it... not a problem on your end... my composer cache was corrupted somehow... once I cleared the composer cache the install went through ok....

    Oh.. but there was an error on the install because the config/app cipher was quoted... I also had to upgrade the cipher, because I use a new homestead and it doesn't include MCRYPT_RIJNDAEL_128 anymore... below is what I changed in case it helps anyone else

    'cipher' => 'AES-256-CBC', // MCRYPT_RIJNDAEL_128,

    Yeah, I'll definitely try the V2 version.... There are many Laravel features/updates I want in L5.3 and 5.4.

    I noticed on the forum that you went back to Laravel 5.3 because of breaking changes in 5.4? Is that still an issue... Is there an easy way (just update the composer.json? ) to go to L5.4... If I find problems I can fix, I'll contribute them..



  • Sorry, meant to write "the config/app cipher was NOT quoted"


  • Global Moderator

    @bgies

    Actually, v2 is the main version for quite some time, almost no fixes changes are beeing applied to v1. The only reason it's still v1 on the master branch is because of the new sub split setup of v2 and couple module fixes not done yet.

    Yeah about Laravel versions, it's currently locked at 5.3.19 because 5.3.20 did a minor patch breaking change (Laravel loves to do this). By this PR

    Also, there is a roadmap issue by @mikemand on github for 5.4

    Your always welcome trying on for Laravel 5.4 and catch or submit any fixes :)


Log in to reply
 

Looks like your connection to AsgardCms was lost, please wait while we try to reconnect.