View [x] not found once cloned in another device?



  • It was working on my local and testing environment but once I cloned the project onto my another laptop and I keep getting view [default] not found or View [partials.notifications] not found or View [layouts.account] not found. So, I can neither view front end or log in to backend.

    I'm using a custom Theme for frontend and AdminLTE for backend but somehow it's not pointing to backend or frontend theme. It's looking for laravel default views in like for example Modules/User/Resources/views/public/login.blade.php

    When I cloned, I did a composer install, chmod for bootstrap cache, bower and npm install . Generated key and cleared config cache.
    I imported the database and updated the env file.
    Then, I ran it with php artisan serve.

    I've tired

    • clearing bootstrap cache,
    • config cache,
    • directly running from localhost without doing serve
    • reverted back to earlier commits

    Nothing seems to work but it's still working in my other PC and in a testing environment.

    Am I missing some step? I've seen a similar post on here but there was no solution.



  • I forgot to reply to this but this was solved by changing installed to true "INSTALLED=true" in env file.


Log in to reply
 

Looks like your connection to AsgardCms was lost, please wait while we try to reconnect.