Routing issue



  • Hi,

    I am trying to setup a module which handles 'client accounts', so separate from the usual auth.

    I created it with the scaffold and have used the User module as a reference as the documentation is extremely lacking.

    I have no problem with backend routes at the moment from what I can tell, however the problem I am having is that my frontend post route defined in frontendRoutes.php is not hitting the controller and I'm also getting a 404 when I set it to a different URL.

    I have defined frontendRoutes.php in the modules RouteServiceProvider.php, and I am also able to see my route loaded when I use php artisan route:list

    When I hit the submit button on my form, if I am using the same URL as the page i.e. client/register - it just redirects back to the register page like its hitting the get route.

    When i change it to something like client/create - I then get a 404 (NotFoundHttpException). It is not hitting my controller function at all as I have a logging command in it and I'm also trying to use XDebug.

    Here is my frontendRoutes.php file: http://pastebin.com/m8B0EKUL

    Here is my ClientAuthController.php file: http://pastebin.com/snqKJJaS

    My form is a POST and it's destination is the route listed in frontendRoutes.php

    Any help will be greatly be appreciated.


  • admin

    Hello,

    That's probably because those URI names are already used by the user module.


Log in to reply
 

Looks like your connection to AsgardCms was lost, please wait while we try to reconnect.