Choosing another single locale (not english) causes bugs



  • I set locale of the project to russian and then deleted the english locale.
    After uploading project to online server it didnt worked, just showed a message: smth went wrong.
    Then i saw that web site is trying to go on /en page, though english is locale is deleted. I put english locale back and uploaded project, then only it started working.
    Now one more thing appeared: after turning on english locale, forms stopped sending $request data on local machine. As i deleted english locale everything works fine.
    I didnt touched the code of the core or any presets within the core was just interacting with scaffolded modules. And while developing was deleting translatable fields as shown in video.
    Going only with instructions from youtube screencasts.
    So looks like smth with locales, i mean maybe it was never tested before with another one locale set, different than english.
    So good luck guys, wish your project to grow in all the directions.


  • admin

    Hello,

    I didn't have any issues with removing the English locale on multiple projects, and only having a single locale.

    Please test your site locally before uploading to server. This will show you the actual error, instead of just "something went wrong".



  • Locally site works perfectly. Problem start appear as i upload it to online server.
    And: whoops something went wrong - is common laravel phrase, whenever smth goes wrong.)
    Anyway thanks for your attention. I found the way to deal with the problems Im facing.
    And will test asgard further so if problem will occur once again, i ll write back.


Log in to reply
 

Looks like your connection to AsgardCms was lost, please wait while we try to reconnect.