Upgrade to 2.0



  • Hi

    I have started to develop a site using AsgardCms, and I have been very impressed with it so far.

    However I was wondering about the 2.0 version of the cms as I see that it is actively being developed on GitHub. When is the planned release date for the stable 2.0 version? If I start the development of my site using 1.0 now, will it be possible to upgrade to 2.0 with relative ease?

    Thanks.


  • admin

    Hello,

    You saw right, version 2.0 is actively being worked on. :)

    I plan on releasing it as soon as possible after laravel 5.3 comes out, end on July. Meaning after used packages are up to date with 5.3.

    Upgrade from 1.0 to 2.0 will be possible, but will require some work. First to update to laravel 5.2 then 5.3, and about the couple of breaking changes introduced in asgardcms itself.
    Those changes can already be browsed through. Every module has a changelog.md file which already contains what I'm doing currently. I will also add those on the website documentation itself.

    Since most of the BC are already in v2, I would use v2 if I'd start a new project now. However the last BC that will need to be applied is the upgrade from laravel 5.2 to 5.3, so something to keep in mind.



  • Thank you for the answer. I will use 2.0 then since the planned upgrade is rather soon.

    Is the 'php artisan asgard:install' functionality supposed to work in 2.0 yet?

    I am getting 'Command "asgard:install" is not defined' after creating the project the same way as for 1.0 -
    'composer create-project asgardcms/platform=2.0.x-dev'


  • Global Moderator

    @rudolfsp

    Hey, what kind of system do you run your Asgard 2.0 on?
    OS, php version and any specific thing you can tell.

    I have same problem on my systems, need to try and pinpoint problem.


  • admin

    I heard from someone else who had the same issue, though I can replicate it, it shows the command as available.

    I'm not sure why it wouldn't show up.



  • It was working for me for 1.0.

    I run Arch Linux and PHP 7.

    Another thing I notice is that there are less (compared to 1.0) postUpdate scripts run after composer create-project..

    I will give an update once I figure out more.


  • Global Moderator

    @rudolfsp

    Hey, can you try to change 'modules' => base_path('modules'), to 'modules' => base_path('Modules'), in config/modules.php.
    It fixes for me, should be same for you.


  • admin



  • Yes, that worked for me too. Thanks!


Log in to reply
 

Looks like your connection to AsgardCms was lost, please wait while we try to reconnect.